Start a new topic

Unable to open Sub Editor


I have a problem with opening my task in Amara. Every time I am trying to access the subtitle editor it wouldn't open. I have tried 4 different search engines: Opera, Chrome, Firefox and Explorer, I've tried removing adblocks and still I have the same situation which wouldn't change or move:

It worked once or twice just after I installed Opera, but next time I tried to open the editor it would get stuck. Anyone has any idea how to deal with this issue?

1 person has this problem
1 Comment


Since you are on Windows and the problem affects all the browsers, we would recommend checking your system for viruses and malware with the use of several reputable, up-to-date antivirus programs.

As the last resort, if the virus does not seem to be easy to identify and remove, you could try and boot Linux on your computer from a CD disk or a flash drive. This way, you can get clean, virus-free access to the Web and Amara subtitle editor under Linux, while still keeping your old Windows system available for other purposes.

If you manage to detect the culprit and successfully disinfect your computer, it would be awesome if you could share your experience here with other users, since a number of other people are having the same issue and will appreciate any information that might help. Thank you!


Margarita Shamraeva

Login or Signup to post a comment